ממשק משתמש

מתוך Gamemaker

קפיצה אל: ניווט, חיפוש


ממשק משתמש


כאשר אתה מפעיל את Game Maker (גֵיים מֵייקֵר) החלון הבא יוצג:

תמונה:form_main.png


(למעשה, זה מה שתראה כשתפעיל את Game Maker (גֵיים מֵייקֵר) במצב פשוט. במצב מתקדם מספר פרטים נוספים מוצגים.) בצד שמאל, אתה רואה את המשאבים (Resources) השונים המוזכרים לעיל: ספרייטים (Sprites), צלילים (Sounds), רקעים (Backgrounds), אוביקטים (Objects), חדרים (Rooms) ושניים נוספים: מידע על המשחק (Game Information) והגדרות משחק כלליות (Global Game Settings). למעלה יש תפריט וסרגל כלים מוכרים. בפרק זה נתאר בקצרה את הפריטים השונים בתפריט, לחצנים, וכו'. בפרקים הבאים נדון בהם בפירוט. שים לב שניתן להשיג דברים רבים בדרכים שונות: על ידי בחירת הפקודה מהתפריט, על ידי לחיצה בסרגלי הכלים, או על ידי לחיצה בלחצן ימני בעכבר על משאבים (Resources).


תפריט File (קובץ)


בתפריט File (קובץ) תוכל למצוא את הפקודות הרגילות כדי לטעון ולשמור קבצים, ועוד כמה מיוחדים:


  • New (חדש). בחר בפקודה זו כדי להתחיל ליצור משחק חדש. אם המשחק הנוכחי שונה אתה תשאל אם אתה רוצה לשמור אותו. קיים עבורו גם לחצן בסרגל הכלים.
  • Open (פתח). פתח קובץ משחק.ל Game Maker קבצים בעלי סיומת Gmk. אתה יכול גם לפתוח קבצים ישנים Gm6. . אם אתה רוצה לפתוח Gmd. קבצים שנוצרו בגירסה 5 של Game Maker עליך לבחור את סוג הקובץ המתאים בחלקו התחתון של הדיאלוג.אם כי אלו עלולות שלא לפעול כהלכה בגרסה החדשה. יש לחצן על סרגל הכלים של פקודה זו. אתה יכול גם לפתוח את המשחק על ידי גרירת הקובץ לתוך Game Maker .
  • Recent Files (קבצים אחרונים). השתמש בתפריט המשנה כדי לפתוח מחדש קבצים שהשתמשת לאחרונה.
  • Save (שמור). שומר את הקובץ תכנון המשחק תחת השם הנוכחי שלה. אם לא צוין עדיין שם, תתבקש להבחור שם חדש. ניתן להשתמש בפקודה זו כאשר משנים את הקובץ. שוב, יש לחצן סרגל כלים עבורו.
  • Save as (שמור בשם). שומר את הקובץ תכנון המשחק תחת שם אחר. אתה מתבקש לבחור שם חדש.
  • Create Executable (צור קובץ להרצה). לאחר שמשחק מוכן ,אתה כנראה רוצה לתת לאחרים לשחק. באמצעות פקודה זו ניתן ליצור גירסה עצמאית של המשחק. זה יוצר פשוט תוכנית מחשב שאתה יכול לתת לאנשים אחרים כדי לפעיל.
  • Advanced Mode (מצב מתקדם). בעת לחיצה על פקודה זו Game Maker יחליף בין מצב פשוט למצב מתקדם. במצב מתקדם פקודות ומשאבים (Resources) נוספים זמינים.
  • Exit (יציאה). בטח ברור. הקש על יציאה מ-Game Maker. אם תשנה את קובץ המשחק הנוכחי תישאל אם ברצונך לשמור אותו.


תפריט Edit (עריכה)


תפריט Edit (עריכה) מכיל מספר פקודות הקשורות למשאב (Resource) שבחור כעת (אוביקט (Object), ספרייט (Sprite), צליל (Sound), וכו '). בהתאם לסוג המשאב חלק מהפקודות לא יהיו זמינים.


  • Insert Resource (הוסף משאב). הוספת מופע חדש של המשאב הנבחר לפני הנוכחי. לאחר בחירתו יפתח טופס ובו אתה יכול לשנות מאפיינים של משאבים. זה יטופל בפירוט את הפרקים הבאים.
  • Duplicate (שכפל). מעתיק את המשאב הנוכחי ומוסיף אותו. נפתח טופס בו אתה יכול לשנות את המשאב.
  • Delete (מחק). מוחק את המשאבים שנבחרו (או קבוצת משאבים). היזהר. פעולה זאת לא ניתנת לביטול. ובכל מקרה תופיע בקשת אישור לפעולה.
  • Rename (שנה שם). נותן למשאבים שם חדש. ניתן להיעשות זאת גם על טופס מאפיני המשאב.
  • Properties (מאפיינים). השתמש בפקודה זו כדי להעלות את הטופס המאפיינים. שים לב כי כל טפסי המאפינים מופעים בתוך החלון הראשי. אתה יכול לערוך מספר טפסים בו זמנית. אתה יכול גם לערוך את המאפיינים על ידי לחיצה כפולה על המשאב.


שים לב, כל הפקודות האלה ניתן להפעיל גם בדרך אחרת. לחץ באמצעות לחצן העכבר הימני על משאב , וטופס מאפינים מתאים יופיע.


תפריט Resource (משאבים)


בתפריט זה, אתה יכול ליצור משאבים (Resources) חדשים מסוגים שונים. שים לב עבור כל אחד מהם יש גם לחצן בסרגל הכלים וכן במקשי הקיצור.


תפריט Run (הפעלה)


תפריט זה משמש כדי להפעיל את המשחק. ישנן שתי דרכים להפעיל את המשחק.


  • Run Normally (הפעלה רגילה). מפעיל את המשחק באופן רגיל. המשחק מופעל בצורה היעילה ביותר ויתנהג בדיוק כפי שיתנהג כשתפעיל אותו מגירסה עצמאית שתיצור.
  • Run in Debug mode (הפעל במצב בדיקה). מפעיל את המשחק במצב בדיקה (Debug). במצב זה תוכל לבדוק היבטים מסוימים של המשחק, אתה יכול להשהות ולהתקדם צעד צעד בתהליך הפעלת המשחק. תכונה זו שימושית כאשר משהו לא בסדר, אך זהו תהליך מתקדם.


תפריט Window (חלונות)


בתפריט זה תמצא פעולות נפוצות בכדי לנהל את הטפסים הפתוחים בחלון הראשי:


  • Cascade (סדר מדורג). סדר את כל ההחלונות באופן מדורג.
  • Arrange Icons (סדר סמלים). סידור כל הטפסים הממוזערים. (שימושי במיוחד כאשר משנים את גודל החלון הראשי.)
  • Close All (סגור הכל). סגור את כל הטפסים הפתוחים, עבור טפסים ששנו, תשאל באם לשמור את השינויים.


תפריט Help (עזרה)


כאן תמצא פקודות לקבלת עזרה:


  • Contents (תכנים). השתמש בפקודה זו כדי להציג קובץ עזרה זה באנגלית.
  • Online Help (עזרה מקוונת). פקודה זו תפתח אתר באינטרנט בו תוכל לקבל הסברים בנושאים שונים כמו כן תוכל למצוא ערכות לימוד (Tutorials).
  • Upgrade (שידרוג). אתה יכול להשתמש בפקודה זו כדי לשדרג את הגרסה הקלילה (Lite Edition) של Game Maker לגרסה המקצועית (Pro Edition). בגרסה המקצועית (Pro Edition) נוספות תכונות רבות. כאן תוכלו למצוא מידע על אופן השדרוג של התוכנה. לאחר השידרוג תוכל להשתמש בפקודה זו כדי להזין את מפתח הרישום שקיבלת.
  • Web site (אתר באינטרנט). יפתח האתר של Game Maker (גֵיים מֵייקֵר), שם תוכל למצוא מידע נוסף על הגירסה האחרונה של Game Maker ו אוסף של משחקים ומשאבים (Resources) עבור Game Maker. אנו ממליצים לך לבדוק את האתר לפחות פעם בחודש.
  • Forums (פורומים). יפתח אתר הפורומים שם משתמשים עוזרים אחד לשני בנושאים רבים ב Game Maker.
  • About Game Maker (אודות Game Maker). מידע קצר על גירסת Game Maker.


סייר המשאבים (Resources Explorer)


בחלק השמאלי של החלון הראשי תמצא את סייר המשאבים (Resources Explorer). כאן תוכל לראות תצוגת עץ שכל המשאבים (Resources) של המשחק שלך. זה פועל באותה צורה כמו בסייר החלונות, שסביר להניח שאתה מכיר אותו. אם לפריט בעץ יש סימן + לפניו ,ניתן ללחוץ עליו ולראות את המשאבים בתיקיה.לחיצה על סימן - תסתיר אותם שוב. אתה יכול לשנות שם של משאב (Resource) (למעט אלה ברמה העליונה) על ידי בחירתו (לחיצה בודדה בלחצן שמאלי בעכבר) ולאחר מכן הקשת שמו. לחיצה כפולה על משאב תאפשר לערוך את המאפיינים (Properties) שלו. השתמש בלחצן ימני בעכבר כדי לפתוח תפריט פעולות כמו בתפריט Edit (עריכה). אתה יכול לשנות את הסדר של משאבים על ידי לחיצה עליהם עם העכבר כעת החזק את לחצן העכבר לחוץ, וגרור את המשאב למקום המתאים. (כמובן המקום חייב להיות נכון. אתה לא יכול לגרור צליל (Sound) לתוך רשימת ספרייטים (Sprites)).


כלים אישיים

sl
דומיין בעברית  דומיין  דומין  תוכנה לניהול  קשרי לקוחות  CRM, ניהול קשרי לקוחות  דומין בעברית  פורומים  ספרדית  גיבוי